icon - Dvaspi

Dvaspi User Documentation

Thank you for your interest in Coobird's Data Viewing and Selecting Program with Integration (Dvaspi)!

This is the documentation for Dvaspi Version 0.5.

For the most up-to-date version and information on Dvaspi, please visit

Table of Contents


Coobird's Data Viewing and Selecting Program with Integration (Dvaspi) is a Java application whose purpose is to enable the user to view a set of data from a file, select data points from a data set, and numerically integrate a portion of the data set.

Dvaspi is derived from two small programs which were written to aid in producing reports for a laboratory class while the author was attending chemistry lab classes during his university career. The first program was produced to numerically integrate a peak from a comma-separated value data set produced by software recording the voltage levels during an anodic stripping voltammetry experiment. The second program was written to select data points from a tab-delimited text file which was generated by software during a Fourier transform infrared spectroscopy experiment. Combining the functions of these two programs and improving the user interface, Dvaspi was born.

Availabilty and Requirements

Dvaspi is available as a Java Archive (JAR) and requires that the Java 2 Platform Standard Edition Runtime Environment Version 5.0 or higher is installed. The newest version of the Java Runtime Environment is available for download from Sun Microsystems at no cost.

Dvaspi is an open-source project. The source code is distributed under the GNU General Public License (GPL). The source code and binary (executable) is available for download from the Dvapsi project page.

Installing and Running Dvaspi

The Dvaspi application is a Java Archive (JAR) file which can be executed in environments in which the Java SE Runtime Environment is installed.

The downloaded file,, contains the license terms for the use of the program (LICENSE) along with the actual application, Dvaspi.jar.

In Windows, the JAR file itself can be executed by double-clicking the Dvaspi.jar file.

In other operating systems and from the Windows command line by entering java -jar Dvaspi.jar from the directory in which the Dvaspi.jar file is located.

User Interface

Dvaspi interface

The user interface can be separated into four basic parts. The menu bar, graphical display panel, control tabs panel and the status bar. The menu bar is located at the top of the application. The middle of the interface is occupied by two panels, the graphical display (left) and control tabs (right). At the bottom is the status bar.

The majority of the area is occupied by the graphic display and the control tabs panels. The sizes for the two panels can be changed by dragging the slider bar that separates the two panels. By dragging the slider bar to the left, the graphic display panel will be made smaller while the control tabs panel will be made bigger. By dragging the slider to the right, the opposite effect can be achieved. The left and right arrows on the slider bar will hide the graphic display panel and the control tabs panel, respectively. The panels will reappear when clicking on the appropriate arrow.

The menu bar enables access to the many functions of the Dvaspi.

Graphical Display

The graphical display is where all the data sets will be presented graphically. The way the data set is displayed in the graphical display, such as the color of the lines and points, can be configured through the Properties.

Resizing of the graphical display is computing-intensive; when data sets with many points are loaded, it can take a while to redraw the graphical display. To speed up the drawing process, a Fast Graphics mode is available which will reduce the number of points drawn to the display. Fast Graphics mode will be discussed in more detail later.

The background color for the graphical display can be changed through the View → Color → "Background..." menu item.

Control Tabs

The control tabs consists of five tabs:

  1. Data Sets
  2. Selection Table
  3. Window
  4. Console
  5. Properties

Data Sets

Data Sets tab

The Data Sets tab is used to manage the loaded data sets. Data sets are listed with their line color as the identification color. (However, multiple data sets can be displayed in the same color.)

Removing one or more data sets can be achieved by selecting the data sets and then clicking on the "Remove" button.

The "Fit to viewport" button will rescale one or more selected data sets to the size of the graphical display.

To match the viewports of the data sets two or more data sets, select the data sets and click on the "Match viewports" button. A dialog box will appear with four different modes of rescaling the data sets.

Selection Table

Selection Table tab

The Selection Table tab displays the currently selected points in a table.

Points that are selected can be deselected by highlighting the points and clicking on the "Deselect" button.

Similarly, the selected points can be copied to the system clipboard by selecting the desired points and clicking on the "Copy" button. Once the points are copied, they can be pasted into spreadsheet applications such as Excel and Calc along with text editors such as Notepad.


Window tab

The Window tab shows the currently loaded data sets and their viewports.

The solid filled rectangle (thin blue rectangle on the left side) represents the current viewport of the data set. The unfilled rectangle represents the region where the data points of the data set are contained.


Console tab

The Console tab hosts the console which displays messages produced by Dvaspi. Results of processing is also output to the console.


Properties tab

The Properties tab displays the properties of the data set currently selected in the Data Sets tab.

The properies of the data set including the viewport, color, and whether to show lines abd points can be changed here.

Status Bar

The status bar is separated into three parts: 1) The mode indicator, 2) status message and 3) current location indicator.

The mode indicator shows the current processing mode that Dvaspi is set to. When no processing mode is selected, the mode indicator will show "None" as the mode. Only during "None" mode can the user select multiple data sets in the Data Set tab.

The status message displays status messages such as results from the Probe and Select processing modes along with the Integrate process.

The current location indicator displays the location of the mouse cursor while Dvaspi is in one of the processing modes other than "None". The coordinate is in the scale of the data set.



Opens the Open dialog box to select a data set to open. Supported file types include comma-separated value (CSV) files and tab-delimited text files.

By default, Dvaspi will look for *.csv and *.txt files ("All supported formats"), but all files in a directory can be searched by changing the "Files of type:" dropdown box to "All Files". However, attempting to open a file type that is not supported can lead to errors. For detailed information about how opening files work, refer to the Opening Data Files section.

Export As...

Exports the image shown on the graphical display to a image file. The supported file formats are JPEG and PNG.

This function does not override the Fast Graphics option. Enabling Fast Graphics can exclude points while displaying them to the graphical display. The same will occur when performing an export to image with Fast Graphics is enabled. For more information, refer to the Fast Graphics section.

Export Special...

With this export function, the user can specify the dimensions of the exported image file. The supported file formats are JPEG and PNG.

This function does not override the Fast Graphics option. Enabling Fast Graphics can exclude points while displaying them to the graphical display. The same will occur when performing an export to image with Fast Graphics is enabled. For more information, refer to the Fast Graphics section.


Exits Dvaspi.



When this option is checked, points will be displayed for all data sets.


When this option is checked, lines will be displayed for all data sets.


The "Background..." menu item is the only item under the Color menu. It can be used to change the background color of the graphical display.


The only item that can be docked and undocked in Dvaspi is the Properties tab. When the Properties tab is undocked, it will become a


Items in this menu will set the processing mode for Dvaspi. In order to use any of the items in this menu, one data set must be selected for processing in the Data Set tab. Having zero or multiple data sets selected will cause Dvaspi to ask the user to select only one data set.

Only while in "None" mode can multiple data sets be selected for removal, changing view ports, and other tasks that require selection of multiple data sets.


This is the mode when no processing is to take place.


The Select processing mode is used to select and deselect points of a data set. During the Select mode, clicking in the graphical display mode will select/deselect the closest data point from the point of clicking.


Clicking in the graphical display while in Probe mode will display the coordinate of the point clicked in the data set's scale in the status bar and the console.

Closest Point

Clicking in the graphical display while in Closest mode will display the index and coordinate of the closest point in the status bar and the console.


The Integration mode is used to set the baseline of integration. In Dvaspi, integration is not performed from zero, but from a baseline which is set by the user. The baseline is set in this mode by clicking at the starting point of integration in the graphical display and dragging to the end point. A black line will be drawn to signify the baseline. Once the baseline is set, clicking on the Process → Integrate menu item to perform the numerical integration.

Zoom in

By dragging a region in the graphical display, the viewport of the current data set is zoomed in.

Zoom out

Clicking a point in the graphical display will zoom out the current data set's viewport with the clicked point as the center.

Zoom center

The viewport of the current data set is centered to the point clicked.



Performs a numerical integration over the line specified in Integration mode. Results of the integration will be displayed in the status bar and the console.


There are two performance settings which can be enabled or disabled from the Performance menu.

Fast Graphics

Enabling Fast Graphics mode will speed up the drawing of the graphical display when there are many points to draw. In order to speed up the drawing process, when this feature is enabled, some data points and its lines will not be drawn. Keep in mind that using Fash Graphics mode can lead to inaccurate representations of the data set when many points are excluded from the drawing.

During Processing (such as Selecting and Probe), Fast Graphics mode is disabled to show all data points on the display.

Fancy Graphics

By default, Dvaspi uses transparencies when drawing non-selected data sets and zoom-in selection area in Processing mode along with the Window tab. When Fancy Graphics mode is disabled, transparencies are only used in the Window tab. This mode is provided as an option to turn off the transparency effects for environments where using transparencies could negatively affect performance.



Displays the About dialog box. The dialog will display the licensing information of Dvaspi.

Technical Information

Opening Data Files

Dvaspi opens a file and reads them line-by-line to input data points into a data set. The two supported file formats supported by Dvaspi, comma-separated values and tab-delimited text files, both represent one data point by a pair of numbers in one line. When a line is read, Dvaspi will search for either a comma (",") or a tab (the escape character "\t") as the split character, depending on the format being read. When the split character is found once and two numbers are extracted successfully, the two numbers are added as a coordinate (data point) in a data set.

Dvaspi does have an option to read files other than comma-separated or tab-delimited text. When opening such a file, the separating character is set to a space (" ").

When a split character is found more than once, the line will be ignored.

Errors can occur during opening of file, espe. One example is if a split character is found


The integration aspect of the program is acheived by performing an numerical integration using the trapezoidal rule.

Trademark Notice

Microsoft, Windows are registered trademarks of Microsoft Corporation, other trademarks are properties of their respective owners. The author is not affiliated with Microsoft.

Sun, Sun Microsystems, the Sun logo, Java are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and other countries.